Jump to content



Welcome to AstaHost - Dear Guest , Please Register here to get Your own website. - Ask a Question / Express Opinion / Reply w/o Sign-Up!

Toggle shoutbox Shoutbox Open the Shoutbox in a popup

@  yordan : (21 April 2014 - 09:11 PM) Hey, Ritesh, Did You Hear Me?
@  yordan : (14 April 2014 - 05:28 PM) By The Way, This Could Be An Interesting Subject For A Topic, What About Posting This Question? Let's See If Other People Have The Same Feeling Concerning Bootlists!
@  yordan : (13 April 2014 - 09:36 AM) Boot Order : Cd, [Usb,] Hard Drive :D
@  yordan : (11 April 2014 - 07:23 PM) I Simply Let The Bios Do That
@  Ritesh : (11 April 2014 - 10:23 AM) Is It Possible To Launch Fedora Live Cd Or Installation Disk From Hard Drive On Windows Platform Using Grub Mbr File.
@  Ritesh : (11 April 2014 - 10:21 AM) No U Are Not.. Btw.. I Have Question For You.
@  yordan : (10 April 2014 - 08:02 AM) You Are Partially Right.
I Was Not.
Nevertheless, I Am Again :)
@  Ritesh : (09 April 2014 - 07:33 PM) :P
@  Ritesh : (09 April 2014 - 07:33 PM) I Think U R Not..
@  yordan : (09 April 2014 - 09:28 AM) I'm The Master Of The Shoutbox!
@  yordan : (05 April 2014 - 10:32 PM) He-He
@  Ritesh : (04 April 2014 - 06:59 PM) Ha Ha Ha ....
@  yordan : (04 April 2014 - 11:15 AM) Welcome Back, Starscream!
@  yordan : (03 April 2014 - 02:31 PM) And I Hope That He Will Come Back Soon :)
@  yordan : (01 April 2014 - 02:53 PM) Nice, Ritesh Came, I'm Not Home Alone Today.
@  Ritesh : (01 April 2014 - 08:51 AM) Oh!!! Poor Dear Yordan..
@  yordan : (31 March 2014 - 10:02 AM) I'm A Poor Lonesome Cow-Boy
@  yordan : (27 March 2014 - 02:22 PM) He Is Unpatient Due To His Patients!
@  Ritesh : (27 March 2014 - 10:46 AM) :(
@  Ritesh : (27 March 2014 - 10:46 AM) He Is Busy With His Patients.

- - - - -

Linux Only Recognises Usb Drive As Read-only


8 replies to this topic

#1 Guest_Habble_*

Guest_Habble_*
  • Guests

Posted 04 December 2007 - 05:58 AM

Hi.

I have a 2gb Cruzer Micro (USB Drive), that I use for transferring files between computers. It works fine whenever I use computers with Windows, but on Linux it has a problem, it keeps saying the drive's read only. I don't know if this is a bug to do with Linux or just My USB Drive locking itself when it doesn't recognise the OS as Windows.

When I had SuSE 10.1, in GNOME. It would hardly work at all in Nautilus. It was really slow and kept freezing, and I had to use Konqueror.
I now Have Ubuntu 7.10, with GNOME, and I can view and copy files from it fine in the File Browser (Presumably still Nautilus), except when I try to write to it, it says it's a read-only disk. And that's the message I get when I try to change the permissions, as well.

It was a while since I got my usb drive, but I'm pretty sure there weren't any drivers I needed, and even if there were, I'm 99% sure there wouldn't be any for Linux.

So....
Help? Please! :rolleyes:

#2 Sten

Sten

    Oh come on Mrs. B!

  • Members
  • 648 posts
  • Gender:Male
  • Location:Tasmania, Australia

Posted 04 December 2007 - 06:20 AM

i had this problem using my usb drive in kubuntu when i had it. i no i fixed it but i cant remember how. i gather its an k/x/edu/go/ubuntu thing. later on i could go on centOS and see wot it does about my usb drive and if it has the same problem then ill try and fix it and tell you how. although i think it works in centOS.

lol at least u have ubuntu, i have an iso which im not gonna do anything with for a while. i think we're getting a new cd/dvd drive soon, i hope we do anyway, the computer wont recognise mine anymore and when it did it couldnt read or write from and to discs.

#3 polarysekt

polarysekt

    Advanced Member

  • Members
  • 128 posts
  • Location:St. Louis, MO
  • Interests:computers, music

Posted 04 December 2007 - 11:42 PM

for 1 -- what is the filesystem on the drive? since you mentioned windows i would almost guess you might have formatted it with ntfs...

also... linux doesn't allow the chmod command on filesystems that are mounted as read only.... my only suggestion for now would be to try to mount your drive as read/write with permissions for the user with which you login... however, this doesn't work too well for ntfs drives, as most distros of linux support r/w on ntfs drives only partially, and without warranty... obviously, ntfs is a proprietary format --

so really, if it is an ntfs drive, but you want it compatible for read/write with both windows and linux you should look into the fat32 filesystem... as long as you dont want to cram 4gb files on there (i mean 4gb per one file, not total) -- fat32 should work just fine...

however, i distrust Microsoft's format utility, because (at least with the windows 2k version I tried) likes to screw up after wasting about a half an hour...

you might want to look into a linux partitioning utility... i think the one for ubuntu would be "qtparted" --- which you should be able to find with your software updater...
on the other hand, since i use openSUSE (10.3 now) -- i just use the parted utility which is actually encapsulated by YaST2...

<<<MAKE SURE YOU UNMOUNT THE DRIVE BEFORE YOU TRY TO FORMAT IT>>>


I myself have two external hdd's... one i formatted fat32... and the other i formatted ntfs (well, actually the person who gave it to me formatted it in this way...) -- unfortunately i'm stuck on the ntfs drive because it fails repeatedly to format fat32, saying it's too large... which of course is funny, because it's about half the size of my fat32 external... all in all, I gave up because of time, and because I just plugged it into my windows xp system, and have avoided linux for now...
I would reformat it for real, but it's quite timely to distribute my files across my network to the various computers with little space to hold the files... basically i'm poor and running low on quality disk space, so I have to split it up across computers, and reassemble when I reformat the hard drive as ntfs...


all in all, since you said it was a USB stick... i'm pretty sure you should have little or no difficulty formatting it fat32 as it shouldn't be too large...


if you filesystem is in fact fat32 already... then you may just simply have to look into your fstab and see if somehow linux didn't decide to mount it as read-only...


as far as the device is concerned... i'm pretty sure they could care less what operating system you're currently using...

hope this helps at least a little...

#4 Guest_Habble_*

Guest_Habble_*
  • Guests

Posted 05 December 2007 - 07:23 AM

The filesystem on it is FAT. But... I also have another 256mb usb drive using FAT, and that works fine with both Linux and Windows.

#5 ethergeek

ethergeek

    Premium Member

  • [HOSTED]
  • 393 posts
  • Gender:Male
  • Location:Tucson, AZ

Posted 06 December 2007 - 03:22 PM

The filesystem on it is FAT. But... I also have another 256mb usb drive using FAT, and that works fine with both Linux and Windows.


Take a look at the kernel log. You might be getting a ton of filesystem panics that are causing the kernel to pop it on readonly. I get this occasionally when I b0rk one of my truecrypt containers by not unmounting it properly.

dmesg | grep -i panic
will show you any panic messages. If you're seeing alot of them relative to the disk, copy all the files you can to another disk and use dosfsck to fix the FAT partition, or, since you've backed it up anyway, just mkfs.vfat on the sucker so you have a proper FAT32 filesystem on there.

#6 xboxrulz

xboxrulz

    Colonel Panic

  • Members
  • 3,057 posts
  • Gender:Male
  • Location:Toronto, Ontario, Canada
  • myCENTs:59.15

Posted 07 December 2007 - 12:48 AM

can you post what's listed on your /etc/fstab?
Example of FSTAB
Posted Image

xboxrulz

#7 Guest_Habble_*

Guest_Habble_*
  • Guests

Posted 09 December 2007 - 06:10 AM

Here's my fstab:

Posted Image

#8 Sten

Sten

    Oh come on Mrs. B!

  • Members
  • 648 posts
  • Gender:Male
  • Location:Tasmania, Australia

Posted 09 December 2007 - 06:15 AM

how come ur step dad always calls your computer brick? y cant he just keep it as localhost.

i remember when i came to ur house and u had suse. one of the first things i noticed was that it was called brick... i spose if he really wants to...

#9 Guest_(G)axmukher_*

Guest_(G)axmukher_*
  • Guests

Posted 16 August 2010 - 02:50 AM

Linux Only Recognises Usb Drive As Read-onlyLinux Only Recognises Usb Drive As Read-only

Try this:

System > Administration > Disk Utility

Navigate to the flash disk on the left sidebar.

Then, on the right side, "Unmount Volume", then "Mount Volume".

Mine works this way ...

-reply by axmukher

 





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users