Jump to content



Welcome to AstaHost - Dear Guest , Please Register here to get Your own website. - Ask a Question / Express Opinion / Reply w/o Sign-Up!

Toggle shoutbox Shoutbox Open the Shoutbox in a popup

@  yordan : (14 April 2014 - 05:28 PM) By The Way, This Could Be An Interesting Subject For A Topic, What About Posting This Question? Let's See If Other People Have The Same Feeling Concerning Bootlists!
@  yordan : (13 April 2014 - 09:36 AM) Boot Order : Cd, [Usb,] Hard Drive :D
@  yordan : (11 April 2014 - 07:23 PM) I Simply Let The Bios Do That
@  Ritesh : (11 April 2014 - 10:23 AM) Is It Possible To Launch Fedora Live Cd Or Installation Disk From Hard Drive On Windows Platform Using Grub Mbr File.
@  Ritesh : (11 April 2014 - 10:21 AM) No U Are Not.. Btw.. I Have Question For You.
@  yordan : (10 April 2014 - 08:02 AM) You Are Partially Right.
I Was Not.
Nevertheless, I Am Again :)
@  Ritesh : (09 April 2014 - 07:33 PM) :P
@  Ritesh : (09 April 2014 - 07:33 PM) I Think U R Not..
@  yordan : (09 April 2014 - 09:28 AM) I'm The Master Of The Shoutbox!
@  yordan : (05 April 2014 - 10:32 PM) He-He
@  Ritesh : (04 April 2014 - 06:59 PM) Ha Ha Ha ....
@  yordan : (04 April 2014 - 11:15 AM) Welcome Back, Starscream!
@  yordan : (03 April 2014 - 02:31 PM) And I Hope That He Will Come Back Soon :)
@  yordan : (01 April 2014 - 02:53 PM) Nice, Ritesh Came, I'm Not Home Alone Today.
@  Ritesh : (01 April 2014 - 08:51 AM) Oh!!! Poor Dear Yordan..
@  yordan : (31 March 2014 - 10:02 AM) I'm A Poor Lonesome Cow-Boy
@  yordan : (27 March 2014 - 02:22 PM) He Is Unpatient Due To His Patients!
@  Ritesh : (27 March 2014 - 10:46 AM) :(
@  Ritesh : (27 March 2014 - 10:46 AM) He Is Busy With His Patients.
@  yordan : (26 March 2014 - 08:12 PM) Ahsani, Where Are You?

Photo
- - - - -

Apache Server On Xampp Problems in starting Apache service on xampp


30 replies to this topic

#1 Nuwan

Nuwan

    Newbie [ Level 1 ]

  • Members
  • 4 posts

Posted 06 September 2007 - 12:30 PM

Hi...

I downloaded and installed the newest version of xampp. But when i try to start the Apache service it does not get started. The MySql and FileZilla services start without any problem. But the Apache service does not start. It returns with a message saying Apache service not started [-1].
I tried by stopping the windows firewall but didn't have any luck.
If there is anyone who can help me out here i would be really great full.

Thanks in advance.
Nuwan.

#2 faulty.lee

faulty.lee

    Super Member

  • [HOSTED]
  • 500 posts
  • Interests:Electronics, Software Programming, Embedded Programming, Movies, Windows Shopping
  • myCENTs:79.88

Posted 06 September 2007 - 12:42 PM

A very likely chance is that you have IIS install, which comes standard for WinXP, and some installation of other software might have enabled it. Try to check under Services and see if IIS is running, it's name is "IIS Admin" and "World Wide Web Publishing". If so, stop the service, now you should be able to start your apache. If you want to run both concurrently, you need to change the port of either the IIS or the Apache

If this doesn't help, or your IIS is not installed, then look under your apache folder, either together with XAMPP, or for my case it's "C:\Program Files\Apache Group\Apache2". Under the logs folder you should see and error.log file. Open that with notepad, there should be some message indicating the problem. For the IIS case, it will show you that port 80 is in used. The Error.og file is a file that you might want to look into once in a while to see if any major problem is creeping in.

#3 Mark420

Mark420

    The Modernator

  • Members
  • 486 posts
  • Gender:Male
  • Location:The Interweb!

Posted 06 September 2007 - 11:57 PM

I use XAMMP also on a daily basis and the only time I have seen any installation problems is when IIS involved, follow the steps above from Lee and you shouls get sorted out.
XAMMP is the easiest and best way to simulate the services we offer here on your home pc, a lot of us use it and are experts on it so feel free to tell us how you get on with it :blink:

#4 Nuwan

Nuwan

    Newbie [ Level 1 ]

  • Members
  • 4 posts

Posted 07 September 2007 - 03:27 AM

Hi guys...

I finally got the apache service running. I checked whether i had IIS installed. But i hadn't got IIS installed. So probably it had to be some other issue.
So when i went through my list of services i saw that i had a Apache2.2 service already installed, but when i checked it's path it was not the location that it should have been. It's path was set to another older location where Apcahe service was previously installed. When i try to run the Apache service it goes and looks for the older location. So i deleted the old apache service, uninstalled my current xampp and reinstalled it.
Now i've got it up and running.

Thank You.
Regards,
Nuwan

#5 Sten

Sten

    Oh come on Mrs. B!

  • Members
  • 648 posts
  • Gender:Male
  • Location:Tasmania, Australia

Posted 07 September 2007 - 04:39 AM

i have xampp portable on my jump drive
ive never had any problem with it

i love having protable stuff on my jumpdrive, it doesnt relly on anything that comes on windows!

#6 Quatrux

Quatrux

    the Q

  • [HOSTED]
  • 1,669 posts
  • Gender:Male
  • Location:Lithuania, Vilnius
  • Interests:PHP, MySQL, Oracle, PL/SQL, HTML, CSS, Javascript, jQuery, C# Computers, Alternative OS, Amiga, MorphOS, Beer, Friends, Linux, KDE..
  • myCENTs:30.76

Posted 07 September 2007 - 05:33 AM

Also, if someone will be reading this post by searching google or also will be having similar problems, another thing which might be the problem that you have Skype installed, so if you are installing a server such an apache which requires port 80 by default, you should turn Skype off or any other software which might be using the port 80 as alternative or as primary, as I know Skype has a check-box wheaver to use port 80 as alternative or not..

Moreover, it is a good advice to run software, apache in this case through a console/dos/cmd/shell/cli whatever because usually you get the error message if it wasn't successful to start the service. :blink:

#7 faulty.lee

faulty.lee

    Super Member

  • [HOSTED]
  • 500 posts
  • Interests:Electronics, Software Programming, Embedded Programming, Movies, Windows Shopping
  • myCENTs:79.88

Posted 07 September 2007 - 12:54 PM

Also, if someone will be reading this post by searching google or also will be having similar problems, another thing which might be the problem that you have Skype installed, so if you are installing a server such an apache which requires port 80 by default, you should turn Skype off or any other software which might be using the port 80 as alternative or as primary, as I know Skype has a check-box wheaver to use port 80 as alternative or not..

Moreover, it is a good advice to run software, apache in this case through a console/dos/cmd/shell/cli whatever because usually you get the error message if it wasn't successful to start the service. :blink:

The alternative for skype to use port 80 is to bypass some system where they block those messaging and voip client. Generally port 80 is left untouch

#8 turbopowerdmaxsteel

turbopowerdmaxsteel

    Premium Member

  • [HOSTED]
  • 449 posts
  • Gender:Male
  • Location:Kolkata, India
  • Interests:Programming, Gaming, Cricket, Listening to Music and watching action cartoons.
  • myCENTs:30.99

Posted 08 September 2007 - 08:10 AM

Hi...

I downloaded and installed the newest version of xampp. But when i try to start the Apache service it does not get started. The MySql and FileZilla services start without any problem. But the Apache service does not start. It returns with a message saying Apache service not started [-1].
I tried by stopping the windows firewall but didn't have any luck.
If there is anyone who can help me out here i would be really great full.

Thanks in advance.
Nuwan.


As mentioned by Quantrux and faulty.lee, the problem is because of having another software bound to port 80. Microsoft IIS is the most common troubler. Others include the lightweight, EasyPHP. You can make IIS and XAMPP Apacher work together. To do this, go to website properties in IIS and change the port number to any free port like 8080.

#9 Sten

Sten

    Oh come on Mrs. B!

  • Members
  • 648 posts
  • Gender:Male
  • Location:Tasmania, Australia

Posted 08 September 2007 - 08:15 AM

im having another problem sort of to do with xampp...

root@localhost doesnt have permission to do anything, which is a problem because i cant make databases or do anything with it.
it ses to edit config.inc.php but yeah... wot do i edit? cos the host is localhost and the user is root.

help? cos i usually try things on my computer before i upload.

#10 Guest_(G)Author Name - e.g. John, Mike_*

Guest_(G)Author Name - e.g. John, Mike_*
  • Guests

Posted 02 March 2009 - 10:24 PM

Cool, thanks, I just killed  the Skype and Apache can be started now!



#11 Guest_(G)Author Name - e.g. John, Mike_*

Guest_(G)Author Name - e.g. John, Mike_*
  • Guests

Posted 22 March 2009 - 02:13 AM

Wow faulty.Lee, man your amazing and u were totally right!

I did google search it and I was looking for hours

then u told us about skype, I turned it off and it finally worked!

I dnt know how much to thank u bro

your amazing thank so soooo much!



#12 Guest_(G)shrek_*

Guest_(G)shrek_*
  • Guests

Posted 19 April 2009 - 06:35 PM

Problem Installing Xampp on Vista BasicApache Server On Xampp

Hi,

 I have windows vista basic on my computer, I have the zip file downloaded and followed all the installations correctly. But still my apache doesnt remain started, Mysql is working fine. I read in the thread about trying using cmd..I dint get any syntax error, it was saying as syntax ok. I installed and uninstalled couple of times. I have no clue wat the problem is please help me ! thanks 

-reply by shrek

 



#13 Guest_(G)Joseph_*

Guest_(G)Joseph_*
  • Guests

Posted 09 July 2009 - 12:34 PM

Hi...

  You guys helped me a lot... In figuring out why my apache has not been running... Thank you very much... I should add to these conversations that if the path of the appache is not right in Sevices.Msc... Then go into the Xammp installation folder find Apache folder; in that uninstall Apache as service and reinstall Apache as service... Doing that has fixed my problem rather than uninstalling the Xampp itself... 

Any ways thank you...

-reply by Joseph

#14 Guest_(G)hsanatolia_*

Guest_(G)hsanatolia_*
  • Guests

Posted 20 July 2009 - 12:25 PM

I really appriciate ..Apache Server On Xampp

Thank you ,I really appreciate your answer ,It was the answer which  I have been looking for /txtmngr/images/smileys/smiley1.Gif

-reply by hsanatolia

#15 Guest_(G)klavdij_*

Guest_(G)klavdij_*
  • Guests

Posted 02 November 2009 - 01:42 PM

skype solved my problemApache Server On Xampp

I have Vista x64 and no IIS (as far as I know) ... Turning skype off enabled start of Apache service... Tnx guys !

-reply by klavdij

 



#16 Kaemon

Kaemon

    Newbie [ Level 1 ]

  • Members
  • 1 posts

Posted 14 November 2009 - 10:37 PM

If XAMPP Apache won't start...
and your not running IIS...
and you're not running Skype...

...Continue reading. Solution below (Windows)

First, open C:\xampp\apache\logs\error.log and see what the error is.

If the error says that a port is already in use, the instructions below will explain how you can determine which application is using that port (Windows).

My error log entry said that Port 443 was already being used (and I wasn't running IIS or Skype)

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down

To determine which application is using Port 443 (or port 80), do the following (Windows)

1. Open a DOS window - Start | Run | "CMD"
2. Type the following: netstat -aon
3. Find the local address using :443 (example: 127.0.0.0:443)
4. Now find the PID associated with that active connection (last column) - This is the application that's using that port.
5. To figure out what application is associated with that PID, do the following:
6. Open Task Manager (Ctrl+Alt+Del) and select the Processes tab.

By default, you will only see the following columns in the Process Tab:
- Image Name
- UserName
- CPU
- Mem Usage

7. Click View from the dropdown menu, "Select Columns...", and then place a check next to PID (Process Identifier) - you will now be able to see the PID for each

8. Find which application (Image Name) is associated with the PID

You have now identified which application is screwing up your Apache Service.

btw, my problem was PMB.EXE, which is Pando Media Booster. Pando Media Booster is the Peer-to-Peer downloader client for Dungeons and Dragons Online. As soon as I uninstalled it, Apache started no problem.

I hope that helped.

#17 yordan

yordan

    Way Out Of Control - You need a life :)

  • [MODERATOR]
  • 4,745 posts

Posted 14 November 2009 - 11:48 PM

7. Click View from the dropdown menu, "Select Columns...", and then place a check next to PID (Process Identifier) - you will now be able to see the PID for each

Wow! I even did not know that we could "select columns" and see the PID. Thanks, this was useful.
Do you think this works with vista too?

#18 starscream

starscream

    Super Member

  • Members
  • 896 posts
  • Gender:Male
  • Location:Land of Shadows
  • myCENTs:84.35

Posted 15 November 2009 - 05:43 AM

btw, my problem was PMB.EXE, which is Pando Media Booster. Pando Media Booster is the Peer-to-Peer downloader client for Dungeons and Dragons Online. As soon as I uninstalled it, Apache started no problem.


This maybe because of both of the programs requiring same ports for working. Or maybe both need resource from same services. Not sure which one they need though. Perhaps asking this questing on PMB/XAMPP will tell you about the system resources they take and that will explain why there is conflict between two.

Nice info by the way.

#19 HannahI

HannahI

    Premium Member

  • Members
  • 442 posts
  • Location:Northeast, United States of America
  • myCENTs:READY[561.92]

Posted 16 November 2009 - 09:16 PM

Why do you want both? They both do the exact same thing.

#20 Guest_(G)Arshad_*

Guest_(G)Arshad_*
  • Guests

Posted 24 November 2009 - 01:58 PM

I was having same problem, xampp and mysql both can not be started on my vista 32bit. I figured out that was due to not having full permission to logged user. I right click on installed xampp directory and give full permission to logged user. That solved my xampp problem.

-reply by Arshad



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users