Jump to content



Welcome to AstaHost - Dear Guest , Please Register here to get Your own website. - Ask a Question / Express Opinion / Reply w/o Sign-Up!

Toggle shoutbox Shoutbox Open the Shoutbox in a popup

@  yordan : (21 April 2014 - 09:11 PM) Hey, Ritesh, Did You Hear Me?
@  yordan : (14 April 2014 - 05:28 PM) By The Way, This Could Be An Interesting Subject For A Topic, What About Posting This Question? Let's See If Other People Have The Same Feeling Concerning Bootlists!
@  yordan : (13 April 2014 - 09:36 AM) Boot Order : Cd, [Usb,] Hard Drive :D
@  yordan : (11 April 2014 - 07:23 PM) I Simply Let The Bios Do That
@  Ritesh : (11 April 2014 - 10:23 AM) Is It Possible To Launch Fedora Live Cd Or Installation Disk From Hard Drive On Windows Platform Using Grub Mbr File.
@  Ritesh : (11 April 2014 - 10:21 AM) No U Are Not.. Btw.. I Have Question For You.
@  yordan : (10 April 2014 - 08:02 AM) You Are Partially Right.
I Was Not.
Nevertheless, I Am Again :)
@  Ritesh : (09 April 2014 - 07:33 PM) :P
@  Ritesh : (09 April 2014 - 07:33 PM) I Think U R Not..
@  yordan : (09 April 2014 - 09:28 AM) I'm The Master Of The Shoutbox!
@  yordan : (05 April 2014 - 10:32 PM) He-He
@  Ritesh : (04 April 2014 - 06:59 PM) Ha Ha Ha ....
@  yordan : (04 April 2014 - 11:15 AM) Welcome Back, Starscream!
@  yordan : (03 April 2014 - 02:31 PM) And I Hope That He Will Come Back Soon :)
@  yordan : (01 April 2014 - 02:53 PM) Nice, Ritesh Came, I'm Not Home Alone Today.
@  Ritesh : (01 April 2014 - 08:51 AM) Oh!!! Poor Dear Yordan..
@  yordan : (31 March 2014 - 10:02 AM) I'm A Poor Lonesome Cow-Boy
@  yordan : (27 March 2014 - 02:22 PM) He Is Unpatient Due To His Patients!
@  Ritesh : (27 March 2014 - 10:46 AM) :(
@  Ritesh : (27 March 2014 - 10:46 AM) He Is Busy With His Patients.

Photo
- - - - -

Help: Setting Default Index Page on XAMPP Web-Server Need some Help


12 replies to this topic

#1 Jimmy89

Jimmy89

    Living at the Datacenter

  • [HOSTED]
  • 713 posts
  • Gender:Male
  • Location:Australia
  • myCENTs:14.01

Posted 29 January 2007 - 11:03 PM

i have just installed XAMMP (win32 version) onto a spare computer just to see if i could get my own home web server going. the install went fine and i managed to get all the of components installed.

but, when i go to http://localhost/ it directs me to the administrator page (http://localhost/xampp/) and not to my htdocs folder where all my files are stored.

when i type in http://localhost/index.html this will take me to the page i want, but i want to be able to just type in localhost or the IP address of the computer to access the page!

how is there a way of doing this, or am I just have to keep entering the page name after localhost each time

thanks for your help
-jimmy

#2 toby

toby

    Super Member

  • Members
  • 611 posts

Posted 30 January 2007 - 10:18 AM

Either edit the php.ini (I hated Xampp, so not sure), or add something to your hosts file to direct something like www.local.host to that file.

#3 Jimmy89

Jimmy89

    Living at the Datacenter

  • [HOSTED]
  • 713 posts
  • Gender:Male
  • Location:Australia
  • myCENTs:14.01

Posted 31 January 2007 - 11:53 AM

thanks. im actually away from my computer now, so i'll give it a go and get back to you!

thanks
-jimmy

#4 Guest_iGuest-Jacques_*

Guest_iGuest-Jacques_*
  • Guests

Posted 12 August 2008 - 01:14 PM

PHP Admin
Help: Setting Default Index Page on XAMPP Web-Server

Http://localhost worked before I change the "file"(php test sites) folder directory to test. Now my pages work but I can't get onto the PHP/MySQL home page where you configure the databases. Please help!

-question by Jacques

#5 Guest_iGuest-Ashwin Perti_*

Guest_iGuest-Ashwin Perti_*
  • Guests

Posted 07 November 2008 - 09:20 AM

not able to work in xampp
Help: Setting Default Index Page on XAMPP Web-Server

I had installed xampp sucessfully, but the problem is that I am unable to see the welcome apge from where.

I can go to PhpMyAdmin.

-question by Ashwin Perti
-------------- admin reply ----------

Execute XAMPP and make sure APACHE is running.
Open your Browser and type :- http://localhost/

#6 Guest_iGuest-mike_*

Guest_iGuest-mike_*
  • Guests

Posted 09 November 2008 - 03:07 AM

Help: Setting Default Index Page on XAMPP Web-Server - Need some Help!
Help: Setting Default Index Page on XAMPP Web-Server

Replying to iGuest
Just copy the xampp folder into your test directory and you should be fine.
Just make sure you keep it in the root of your working directory.

-reply by mike

#7 magiccode9

magiccode9

    Advanced Member

  • [HOSTED]
  • 162 posts
  • Gender:Male
  • myCENTs:77.89

Posted 26 November 2008 - 11:03 PM

You could change the default index file by opening httpd.conf file.

Open httpd.conf from path your have installed xmpserver or apache2\conf directory.
find a string "<Directory>" that includes an value that point to your document root directory.

Add or change a line that start with "DirectoryIndex ..." to "DirectoryIndex index.html index.php"

e.g.
For instance, you have installed xmpserver or apache2 to c:\program files\xmpserver2
then xmpserver_root = c:\program files\xmpserver2

Open the httpd.conf file from a path like [xmpserver_root]\conf\httpd.conf

Search for a string that look like this, "<Directory '[xmpserver_root]'>"
Then, add or modify the setting of "DirectoryIndex" look like this,

DirectoryIndex `page list`

the page list is a space separated list of default you wish server to use when a request arrived to the server, such as,

DirectoryIndex index.html index.php

save and restart xmpserver or apache2 server and test it.

P.S Besides the above method. You may also put the DirectoryIndex directive outside of any Directory directive.

#8 Guest_(G)Abyooda_*

Guest_(G)Abyooda_*
  • Guests

Posted 29 July 2009 - 01:17 PM

Index PageHelp: Setting Default Index Page on XAMPP Web-Server

I am in love with XAMPP Apache server, I don't like the Microsoft policies, long live freedom..

to let your index.Html work instead of the http://localhost/xampp/, simply go to the htdocs folder and delete the index.Php file

-reply by Abyooda



#9 Guest_(G)Udayakumar_*

Guest_(G)Udayakumar_*
  • Guests

Posted 09 September 2009 - 10:56 AM

Viewing and editing the Index page - XamppHelp: Setting Default Index Page on XAMPP Web-Server

Hi Ashwini,

The index file/ home page will be stored in /Xampp/htdocs . It can be either a index.Php or index.Html. You can edit one and rename the other one so that you can view your home page by opening your browser and typing in http://localhost.

Feel free to ask questions here.

-reply by Udayakumar



#10 Guest_(G)_*

Guest_(G)_*
  • Guests

Posted 10 October 2009 - 09:48 PM

For those that don't want to delete the index.Php file, there is a line when you open up that file that says: header('Location: '.$uri.'/xampp/'); 

You can change the '/xampp/' to '/index.Html' or whatever else you have happen to want the default webpage to open up as.  



#11 Guest_(G)Will_*

Guest_(G)Will_*
  • Guests

Posted 10 November 2009 - 03:31 PM

Problem with XAMPP directory and loading websiteHelp: Setting Default Index Page on XAMPP Web-Server

Hi guys, I hope some one with more experience can help meOut with this frustrating problem.

 

I want to practice some PHP and infrastructure tests on thisDynamic website that I have access too, without ruining the website if I makeSome mistakes.

 

Ive installed XAMPP successfully, but now I have the problemOf getting it to run the website correctly.

 

I deleted the original index.Html and index.Php files thatWere in the xampp/htdocs area.

I than copied and pasted all of the files from my websiteInto this directory.

 

 

I just changed the,

1. Locate XAMPP install directory

2. Open php/php.Ini

3. Do a search for the word ‘curl’ and uncomment (remove theLeading semicolon) that line

4. Save & close

 

But there was no, php.Ini file in apache/bin/php.Ini so that was is unchanged.

 

 

Now when I go to,

https://localhost/mywebsitename.Com/

the home page works, but when I click on a link on my homePage it goes to the actual page online;

http://www.Mywebsitename.Com/subfile.Php

 

Some of the links from the home page go to

https://localhost/afileonmysite.Php

 

but than an "Object not found!" screen appears.

 

I have a feeling that my directory is not setup correctly.Maybe someone could guide me in the right direction

 

Thanks Will-

 



#12 Guest_(G)Praveenkumar. PK_*

Guest_(G)Praveenkumar. PK_*
  • Guests

Posted 27 January 2010 - 06:12 AM

Thanks for the helpHelp: Setting Default Index Page on XAMPP Web-Server

Dear sir/madam,

 Thanks for the timely help. When I work in php with mysql, the index.Php has worked without modified any  configuration file.  But now I am working in Postgres  I could not able to start with the default index.Php with out typing in the address bar. When I give the index.Php in the address bar then only it shows the page otherwise it shows the directory list. So when I saw your comments on this, I follow the comments. Now it is working without typing the index.Php..

Thank you once again...

Bye bye take care...

 Regards,

Pk. PK 

 



#13 Guest_(G)Tony_*

Guest_(G)Tony_*
  • Guests

Posted 15 February 2011 - 07:58 PM

Got some input on this one.Help: Setting Default Index Page on XAMPP Web-Server

I had the same problem.  My local version redirecting to to /xampp when all I wanted was http://localhost.

First:  index.Php is designed to redirect to /xampp ( header('Location: '.$uri.'/xampp/'); )

I didn't want to mess with this file, if you do then replace the contents or delete the file and the redirect will go away...

I wanted to work on the index.Html, but because of the DirectoryIndex entry in httpd.Conf, it always opted for the index.Php, instead of the index.Html file, because index.Php was before index.Html in the file list.

When a directory request (e.G. http://localhost) is made to Apache it determines the file to respond with by looking at the list of files defined in DirectoryIndex in the order that they are listed.  So, I moved index.Html to the front of the DirectoryIndex list, so Apache "finds" it and responds with index.Html.

Of course, if I delete index.Html it will look for and find index.Php...

Of course, if I renamed index.Php to something not in DirectoryList it would solve the problem as well.

-reply by Tony



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users