Jump to content



Welcome to AstaHost - Dear Guest , Please Register here to get Your own website. - Ask a Question / Express Opinion / Reply w/o Sign-Up!

Toggle shoutbox Shoutbox Open the Shoutbox in a popup

@  yordan : (14 April 2014 - 05:28 PM) By The Way, This Could Be An Interesting Subject For A Topic, What About Posting This Question? Let's See If Other People Have The Same Feeling Concerning Bootlists!
@  yordan : (13 April 2014 - 09:36 AM) Boot Order : Cd, [Usb,] Hard Drive :D
@  yordan : (11 April 2014 - 07:23 PM) I Simply Let The Bios Do That
@  Ritesh : (11 April 2014 - 10:23 AM) Is It Possible To Launch Fedora Live Cd Or Installation Disk From Hard Drive On Windows Platform Using Grub Mbr File.
@  Ritesh : (11 April 2014 - 10:21 AM) No U Are Not.. Btw.. I Have Question For You.
@  yordan : (10 April 2014 - 08:02 AM) You Are Partially Right.
I Was Not.
Nevertheless, I Am Again :)
@  Ritesh : (09 April 2014 - 07:33 PM) :P
@  Ritesh : (09 April 2014 - 07:33 PM) I Think U R Not..
@  yordan : (09 April 2014 - 09:28 AM) I'm The Master Of The Shoutbox!
@  yordan : (05 April 2014 - 10:32 PM) He-He
@  Ritesh : (04 April 2014 - 06:59 PM) Ha Ha Ha ....
@  yordan : (04 April 2014 - 11:15 AM) Welcome Back, Starscream!
@  yordan : (03 April 2014 - 02:31 PM) And I Hope That He Will Come Back Soon :)
@  yordan : (01 April 2014 - 02:53 PM) Nice, Ritesh Came, I'm Not Home Alone Today.
@  Ritesh : (01 April 2014 - 08:51 AM) Oh!!! Poor Dear Yordan..
@  yordan : (31 March 2014 - 10:02 AM) I'm A Poor Lonesome Cow-Boy
@  yordan : (27 March 2014 - 02:22 PM) He Is Unpatient Due To His Patients!
@  Ritesh : (27 March 2014 - 10:46 AM) :(
@  Ritesh : (27 March 2014 - 10:46 AM) He Is Busy With His Patients.
@  yordan : (26 March 2014 - 08:12 PM) Ahsani, Where Are You?

Photo
- - - - -

Deleting A Corrupt File Cannot delete a corrupt file on Windows XP...


37 replies to this topic

#1 szupie

szupie

    S.P.A.M.S.W.A.T.

  • Members
  • 814 posts
  • Gender:Male

Posted 19 October 2006 - 12:06 PM

I was upgrading some software and came across a corrupt file that halted the installation process. I went to see what was wrong with the file, and failed to manually delete it. I tried moving (cut&paste) it to another location, and the installation succeeded. However, the file is still on my drive, taking up a KB of space. I know that's not a lot, but where am I supposed to put it? In a folder created especially for all the corrupt files on my computer? :P

I've heard something about using the chkdsk utility to fix the problem. However, I am not sure on how to use this tool. Microsoft's documentation didn't make it clear...

#2 tommydanger

tommydanger

    Member [ Level 1 ]

  • Members
  • 42 posts

Posted 19 October 2006 - 01:36 PM

Use Unlocker:
http://ccollomb.free.fr/unlocker/
It's an explorer extension.
It calls itself automatically whenever the deleting process failed.
It frees all the calls to the file, so you can delete it, but it does not work always (atleast for me)
You can also choose if you want to delete the file after a reboot.
But other than that its a pretty handy program :P

#3 yordan

yordan

    Way Out Of Control - You need a life :)

  • [MODERATOR]
  • 4,744 posts

Posted 19 October 2006 - 02:46 PM

Booting on the Knoppix CD also helps.
You are under windows then, having less problems. You click on your Windows partition, choose mount, choose switch to write-enabled mode, go to your folder, choose your file and choose "delete". Probably the Linux file manager will have no problem deleting this corrupted file.
The only reason I see for being really definitively unable to delete the file would be a physical corrupted sector on the disk, then, only a disk format would be able to recover the error.
Regards
yordan

#4 pyost

pyost

    Way Out Of Control - You need a life :)

  • Members
  • 1,090 posts
  • Gender:Male
  • Location:Vancouver, British Columbia
  • myCENTs:67.69

Posted 19 October 2006 - 02:51 PM

If my memory serves me well, I have had the same problem some time ago. I can't remember exactly what helped, but trying to delete it in DOS mode seems like a good idea. Also, you might want to try booting Windows in Safe Mode and then deleting the corrupted file.

#5 yordan

yordan

    Way Out Of Control - You need a life :)

  • [MODERATOR]
  • 4,744 posts

Posted 19 October 2006 - 03:06 PM

've heard something about using the chkdsk utility to fix the problem. However, I am not sure on how to use this tool. Microsoft's documentation didn't make it clear...

By the way, yes, there is a way you can use it harmless.

Open a dos prompt window, and type "chkdsk c:" (or chkdsk d: depending if your file is on C: or D: or E:)
It will tell you "you did not provide the /f flag, I will only look without reparing".
No problem, let it look, and if it says "no errors", then chkdsk is not the solution.
If it finds a problem, run it again with the /f option, like this :
chkdsk d: /F

sometimes it's useful, sometimes not.

#6 foolakadugie

foolakadugie

    Premium Member

  • Members
  • 242 posts
  • Location:Los Angeles

Posted 19 October 2006 - 06:28 PM

Yeah I would probably just delete it from command prompt, but depending on what the file is you might have to go into safemode.

#7 Kyro

Kyro

    Newbie [ Level 2 ]

  • Members
  • 11 posts
  • Interests:History:<br />Started working with computers when that good old C64 was the mainstream, my interest with computers and networking has always been with security. Although I am also interested in cars and how to improve them.<br />Type of Person:<br />I tend to always see the problems with solutions, but this has led to much more robust hardward, software and mechanical systems.<br /><br />Whats I have done:<br />I have advised on software and networking projects along with starting a few of my own. Worked on a number of car restoration and creation projects.<br /><br />My expertise are on soft-system security, hard-system security, software development (design through to implimentation), system support and mechanics.<br />I tend to find that I know alot about nearly everything, just dont come to me if you want to know about history and such. I see little point learning the past when its the future we wish to improve. Though recent history can provide insight into possible scenarios that can arise in the short term future.

Posted 19 October 2006 - 09:17 PM

If you are not confident with the command prompt or Linux, then you can try using GiPo@Utilities.
http://www.gibinsoft...utils/index.htm
GiPo@Utilities has a number of small programes within it.
These include:
* GiPo@MoveOnBoot - copying/moving/renaming/deleting files and folders on the next system boot.
* GiPo@DirMonitor - monitoring changes in the file system.
* GiPo@Mount - local folders substitution and local/remote drives mounting.
* GiPo@Hardlink - UNIX-like (POSIX) hardlinks for NTFS creation.
* GiPo@ReadTest - checking files and folders for read errors.

#8 wutske

wutske

    Way Out Of Control - You need a life :)

  • [HOSTED]
  • 1,443 posts
  • Gender:Male
  • Location:Belgium
  • myCENTs:98.90

Posted 23 October 2006 - 05:09 PM

There's a small catch on using linux. If you have windows installed on an NTFS partition then you should be very carefull with wath you do. Linux NTFS drivers are still very buggy when it comes to writing (deleting = writing) especialy when you write a lot of data. A small amount normaly should pose not too many problems, but it's best to try windows-based software first.

#9 nightfox

nightfox

    NiGHTFoX - Hiding in the dark

  • Members
  • 680 posts

Posted 23 October 2006 - 11:09 PM

Yeah I would probably just delete it from command prompt, but depending on what the file is you might have to go into safemode.

It's always best to just go into safe mode. Then nothing will try to open the file for reading. That's what I like about Linux... it doesn't leech on to a file like that.

[N]F

#10 Guest_FeedBacker_*

Guest_FeedBacker_*
  • Guests

Posted 25 September 2007 - 03:55 PM

Thanx tommydanger 'Unlocker' did the job! Had this annoying avi that refused to budge in Safe Mode or via Command Prompt. Cheers.

-bigpaul

#11 Guest_FeedBacker_*

Guest_FeedBacker_*
  • Guests

Posted 15 December 2007 - 02:55 AM

How do you delete a corrupt AOL file, when it says to run chkdsk utility

-mike

#12 Guest_FeedBacker_*

Guest_FeedBacker_*
  • Guests

Posted 18 December 2007 - 11:59 PM

I tried everything in this thread, including Unlocker and GiPo@Utilities, but I still have the corrupted file that prevents CHKDSK from completing and won't allow me to make a backup image of my drive.

Any other suggestions?

Thank you in advance.

#13 Guest_FeedBacker_*

Guest_FeedBacker_*
  • Guests

Posted 28 January 2008 - 09:05 AM

Replying to yordan

Thank you. Using "chkdsk g: /F" enabled the deletion of a corrupt file on a flash drive.

#14 Guest_FeedBacker_*

Guest_FeedBacker_*
  • Guests

Posted 16 January 2008 - 03:01 AM

Deleting a corrupted file
Deleting A Corrupt File

I am certainly not the most computer savvy person, and I just deleted a corrupt file with the DOS command prompt as specified above. Using the chkdsk feature was so easy. Thanks a lot guys, saved me a lot of frustration. One google search and a little common sense, problem solved.

Thanks again.

Matt

-Matt

#15 Guest_FeedBacker_*

Guest_FeedBacker_*
  • Guests

Posted 07 February 2008 - 07:41 AM

Chkdsk in Command Prompt to delete corrupted files
Deleting A Corrupt File

Replying to yordan

Thanks. Chkdsk in command prompt with the F/ option worked like a dream for me.



-Harry



------------------

You're welcome, Harry, Nice to have been helpful.

Yordan

#16 Guest_FeedBacker_*

Guest_FeedBacker_*
  • Guests

Posted 11 February 2008 - 04:59 AM

Unlocker just worked on my two corrupted hidden system files.





-Greg

#17 Guest_FeedBacker_*

Guest_FeedBacker_*
  • Guests

Posted 04 March 2008 - 03:08 AM

Unlocker worked for me
Deleting A Corrupt File

Yay! unlocker worked for me! I had a file that I coudnt delete and now it did!

#18 xboxrulz

xboxrulz

    Colonel Panic

  • Members
  • 3,057 posts
  • Gender:Male
  • Location:Toronto, Ontario, Canada
  • myCENTs:59.15

Posted 05 March 2008 - 04:35 AM

Interesting, I think I should keep this in mind because a lot of my files get corrupted throughout time.

xboxrulz

#19 Guest_FeedBacker_*

Guest_FeedBacker_*
  • Guests

Posted 07 March 2008 - 03:37 AM

I cant delete a corruppt file, I tried using chkdsk with no results...HELP! Any help would be greatly appreciated

thx, jay

#20 docduke

docduke

    Advanced Member

  • Members
  • 152 posts

Posted 19 March 2008 - 02:37 AM

Having just spent two days figuring out how to delete a corrupt file in Windows NTFS, I can tell you more than you want to know about it. This is on Windows 2000 Pro, so your mileage may vary with other OSs.

First, the GUI Checkdisk will not touch it. It will tell you the disk is fine. (I knew it was not, because my backup program quit with a "read error" message.) The defrag program will treat it as untouchable, and defrag everything else around it.

As others have said, there are many warnings against using Linux to alter NTFS filesystems. The folks who are trying to change this are at Linux-NTFS, and think they have fixed it. Specifically, they say: We just have released ntfsprogs 2.0.0 with full read/write support! So if you have this version, it may be able to do the cleanup.

However, back to doing it in Windows. It turns out that Microsoft has a Knowledge Base Article that relates to this issue. One learns there that the DOS version of chkdsk can do things the GUI version cannot. However, the story is not yet over. If you try to run the DOS chkdsk in the Windows partition you are trying to repair, it will tell you Cannot lock current drive .. the volume is in use by another and refuse to run. You must have a multi-boot system with 2 (or more) Windows partitions, and run chkdsk D: /f /r with "D:" replaced by the drive assigned to the partition with the bad file. Actually, it turns out that chkdsk D: /r will repair it, even though it is not supposed to make any changes without the /f switch. I tried omitting the /f switch because I wanted to test some other options, but the bad sector was removed by that operation.

It's amazing to me that the GUI checkdisk gives a disk with read errors a clean bill of health, but don't forget that this software is from Microsoft. :)



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users